# Table of Contents

1. **Objective** .....................................................................................................................3
2. **Setup & Preparation** .....................................................................................................4
3. **Launching IC Studio** ....................................................................................................5
4. **Creating a project** .........................................................................................................6
   1. Opening icstudio and assigning the project a name...................................................6
   2. Specifying Location Map .........................................................................................7
   3. Specifying Process files and other settings ...............................................................8
5. **Creating a Library and Cells** ........................................................................................9
   1. Create a New Library ..............................................................................................9
   2. Capturing a cell .....................................................................................................10
   3. Design Architect ...................................................................................................11
6. **Schematic Entry.** .......................................................................................................12
   1. Adding Components and Ports .............................................................................12
   2. Wiring the components .........................................................................................13
   3. Adding Text / Changing Labels of Components ....................................................14
   4. Sizing Transistors & Modifying other Properties ...................................................14
7. **Checking & Saving the Schematic** ............................................................................16
8. **Creating a Viewpoint** ...............................................................................................17
9. **Printing the Schematic** .............................................................................................18
10. **Creating a Symbol** ................................................................................................19
1. Objective

This document contains a step-by-step tutorial for Mentor Graphics Design Architect tool to create the schematic of a common source amplifier and to generate a symbol for hierarchal designs.
2. Setup & Preparation

The set of directives listed below is applicable to users of the Engineering Design Center at Santa Clara University. If you are working in a different environment please check with your system administrator.

The steps below are necessary only for the first time to setup the Mentor Graphics environment by changing the settings in your .profile or .cshrc file. Add the following lines in your .profile:

```
setupt mentor-2006.1
alias swd="export MGC_WD='pwd'"
```

Remember to execute

```
$ . .profile
```

If using C-shell add the following lines in your .cshrc:

```
source /usr/local/scripts/setup.mentor-2006.1.csh
alias swd="export MGC_WD='pwd'"
```

Remember to execute

```
$ source .cshrc
```
3. Launching IC Studio

On the command line:

- To Create a directory to contain your projects type: `mkdir analogtut`
- To change the current directory to Tutorial type: `cd analogtut`
- To open ICSTUDIO type: 
  ```
  “icstudio&”
  ```

This launches the ICStudio window shown below.
4. Creating a project

To create a project the follow the three steps given below:

1. Opening icstudio and assigning the project a name

On the ICStudio Window
- Click File > New > Project to create a new project.
- Click Next in the New project pop-up window
- Enter the Project name (e.g. analog_tutorial) and the Project Location i.e., the name of the directory you created (e.g. analogtut) to contain the project, and click Next in the New project pop-up window.
2. Specifying Location Map

On the next window that appears

- Click the **Open Location Map Editor** button. The Location Map Editor appears.
- To Add the *design kit's standard cell libraries* to the location map
  
  Click **Edit Menu > Add Standard MGC Libraries** pull down menu item.

  Following libraries will be automatically added.
  
  - `/opt/mentor-2006.1/app/2006.1_sun4os5/icflow_home/mgc_icstd_lib/mgc_ic_commlib`
  - `/opt/mentor-2006.1/app/2006.1_sun4os5/icflow_home/mgc_icstd_lib/mgc_ic_comm_qs`
  - `/opt/mentor-2006.1/app/2006.1_sun4os5/icflow_home/mgc_icstd_lib/mgc_ic_comm_rf`
  - `/opt/mentor-2006.1/app/2006.1_sun4os5/icflow_home/mgc_icstd_lib/device_lib`
  - `/opt/mentor-2006.1/app/2006.1_sun4os5/icflow_home/mgc_icstd_lib/generic_lib`
  - `/opt/mentor-2006.1/app/2006.1_sun4os5/icflow_home/mgc_icstd_lib/sources_lib`
  - `/opt/mentor-2006.1/app/2006.1_sun4os5/icflow_home/mgc_icstd_lib/mgc_ic_verilog`
  - `/opt/mentor-2006.1/app/2006.1_sun4os5/icflow_home/mgc_icstd_lib/mgc_ic_macrolib`

- Add the **MGC design kit** to the location map
- Click **Edit Menu > Add MGC Design Kit**.
- Specify MGC Design Kit path as **/opt/mentor-2004.3/sol/adk2_5**
- The Library List editor looks as in the figure below.
- Click **OK** on the Library List Editor.
- Click **Next** on the New Project pop-up window.
3. Specifying Process files and other settings

- Click Open Settings Editor button. The Project tab of the Preferences dialog box appears.
- Load the process file (tscm0XX).
  Process files are present in /opt/mentor-2004.3/sol/adk2_5/technology/ic/process
- Load the following rules file to the project: tscm0XX.rules
  Rules files are present in /opt/mentor-2004.3/sol/adk2_5/technology/ic/process
  - DRC rules file: tscm0XX.rules
  - LVS rules file: tscm0XX.calibre.rules
  - SDL rules file: tscm0XX.accusim.rules
  - PEX rules file: tscm0XX.calibre.rules

**NOTE: Select value for XX from 18, 25, and 35 depending on design requirement**
- Fill in any other dialog box field to suit your project needs.
- Click OK on the Preferences dialog box.

- Click Next on the New Project pop-up window.
- View the Summary to make sure all the information is correct.
- Click Finish.
5. Creating a Library and Cells

1. **Create a New Library**
   - Click **New > Library**. This opens the **Create Library** dialog box.
   - Enter the **name of the library** you want to create (e.g. analogtut).
   - Click **OK**.
   
The library appears in the ICstudio library pane as well as in the location map.
2. **Capturing a cell**

To create a new Schematic cell:

- Select a library (e.g. analogtut) where you want a cell view to be created
- Click File > New > View. The Create New View dialog box opens.
- Enter the **Cell Name** (e.g. CommonSource). If the cell does not exist, it is created.
- Specify the **View Type** as Schematic and click **Finish**
3. **Design Architect**

Design Architect (DA-IC) will open automatically where in you can capture the required cell design.

*You will see an empty sheet in the Design Architect window. This sheet is where you will draw your schematic by placing the parts for your circuit and wiring them together. Standard devices and circuits are available in the device lib and MACRO LIB palettes which are accessed by clicking on the Library palette button.*

Click on the Show/Hide Palette Icon indicated below to open Palette Menu. The palette menu will appear on right hand side of the window as shown in the figure below.
6. Schematic Entry

Now let’s start drawing the schematic for the amplifier.

1. Adding Components and Ports

Select the parts for your schematic of the amplifier by choosing from a library of components.

To place transistors on the sheet:
- In the palette menu shown alongside, click on Library.
- In the subsequent palette menu click on Device Lib.
- Select NMOS (4-pin) and place it on the sheet by clicking on the position you wish to place it. Similarly, place ideal resistors and ideal capacitors as shown.
- Click BACK to go to the IC Library palette and click on Generic Lib. Place Portin, Portout, VDD and Ground on the sheet.
2. Wiring the components

To wire up the components:

- Press function key F3 to wire up the components according to the circuit diagram in Figure.
  - Pressing F3 activates the wiring command.
  - Clicking on Cancel in the prompt bar or pressing Esc on your keyboard disables the wire command.
- Alternatively, wires can be added by using the schematic edit palette or from menu bar by clicking ADD > WIRE
3. Adding Text / Changing Labels of Components

To change the value or text associated with any components,
- Point the cursor on that text/value and press **SHIFT + F7**
  (Note You do not have to click/select the text or value. Just point the cursor on the value/text.)
- A display prompt bar appears at the bottom with the current value/text in the **New Value box**. Input the **new name** in this box and click **OK**.

For example:
To change the label **NET** of the **PORTIN** symbol to **VIN**,
- Point the cursor on the text **NET** near the **PORTIN** symbol and press **SHIFT + F7**.
- A display prompt bar appears at the bottom. Type **VIN** in the **New Value box** and click **OK**.

Similarly change the label of **PORTOUT** symbol from **NET** to **VOUT**.

Change the values for the capacitors and resistors by pointing to the value and pressing **SHIFT + F7**.

*Note:* You can also change sizes of transistors, instance names or any other text values associated with any component in the circuit. Alternatively, you can modify multiple properties of a device as explained in the next section.

4. Sizing Transistors & Modifying other Properties

To change multiple properties of one device (e.g. NMOS) at a time:
- Highlight NMOS device, click right mouse button, and select **Properties > Edit**.

In the box that appears, change following properties if needed:

- **INST:** M1
- **L:** 5u (drawn length of device: 5 micron)
- **W:** 5u (width of device: 5 micron)
- **ASIM_MODEL:** NCH (required for simulation)

*Note:* Click on “**Apply**” button every time you change any value.
If you want to prepare a layout of your circuit and run LVS check, you also need to modify following properties. (If you just want to do simulations, you may skip these two properties)

PHY_COMP : \text{mn} \\
INSTPAR : $\text{strcat("w=", W, " l=", L)}$

**Important:** Change the type for INSTPAR property to "expr". Also, you need to type this string carefully, as it is. Specifically, do not forget the spaces in this string, as highlighted below for your reference.

$\text{strcat("w=", <space>W,<space> "<space>l=",<space> L)}$

In case, there is no INSTPAR property (or any other required property) listed in the multiple properties table of a device, insert it in the last blank row of the table.
7. Checking & Saving the Schematic

Now the schematic should look as shown in the figure.

Click **Check & Save** from the **schematic > edit** palette or in the **menu bar** to check and save your sheet.

*Note:* If your sheet does not pass check, you cannot simulate the design. Check the log if errors are listed.

If your sheet passes all checks you will get the following message in the message pane:

Note: "CommonSource/schematic/sheet1" passed check
Note: Registering schematic model with part $analogtut/default.group/logic.views/CommonSource/part : Common Source
Note: Version 1 of part $analogtut/default.group/logic.views/CommonSource/part has been written
Note: Version 1 of sheet $analogtut/default.group/logic.views/CommonSource/schematic/sheet1 has been written
8. Creating a Viewpoint

To prepare for simulation in DA_IC, a Design Viewpoint needs to be created. The tool automatically creates the viewpoint when you enter into simulation mode.

- Click on simulation from the schematic edit palette on the RHS or click on the LHS Vertical Icon Bar to enter the simulation mode.
- Click OK to accept default options and to create a viewpoint. You will use the viewpoint during layout of the circuit.
- Click on end simulation in the Schematic_sim palette or on the LHS Vertical Icon Bar to end the simulation and get back in schematic edit mode.
9. Printing the Schematic

To print the schematic:

- Click **File > Print**
- Enter *laser* in the **Printer name** box. Do not modify any other settings.
- Click **OK**.
10. Creating a Symbol

Hierarchical design allows you to instantiate lower level cells (circuits) into upper level cells to create a tree structure. Since, at higher levels, we really don't need to see the detailed transistor-level description of the base cells, we create symbols for them. Also we will use this symbol to perform various simulations on the circuit in the simulation tutorial.

Make sure that the schematic is checked & saved before making the symbol.

To generate a Symbol Automatically:

- From the menu bar select **Tools > Generate Symbol**
- In the **Generate symbol** dialog box,
  - Click **Choose shape**.
  - Notice that variety of shapes are available for the symbol and one can choose any of these shape that best describes the circuit.
    - Select **Buffer** and click **OK**.
    - Change **Min Height** to 3 so the symbol is large enough for the labels we have used.
    - Click the **OK** button to generate a symbol for the cell.
- The symbol is created automatically and displayed in a new window as shown below. Do not forget to save this symbol by selecting **Check & Save** from the **symbol_draw** palette on the right hand side. You can now use this symbol in other schematics. You can edit symbol by selecting different shapes from right hand palette.

The symbol generated for the amplifier is shown in the figure below.